fbpx

Home Forums Announcements Required SixBit Upgrade by 3/31/2021 Reply To: Required SixBit Upgrade by 3/31/2021

#14186
Barry Shonbeck
Participant

I tried to upgrade but the Release Notes screens shows a script error when I open it.  I use the latest FireFox browser.

Barry

© 2023 SixBit Software. All rights reserved.